Trying to redeem Premium rewards, it says "Whoops, something went wrong"?


#1

Hello all, I just got premium today and went to claim my premium rewards and it says that something went wrong and the page isn’t showing up. Anyone know what the problem is?


#2

Did you buy on a per monthly basis or paid for bulk (6months / 12 months) upfront?


#3

It is a 12 month plan :slight_smile:


#4

Damn, you should have it then.

Tried logging out your account and back in?

Tried to access from another browser?

Im cc @EllisHouslin so he can help more.


#5

I shall try to log out and in real quick :slight_smile:


#6

Update, logged out an in, tried to download one of the free soundpacks, its still the same.


#7

Damn… lemme check mine. Im on Safari.


#8

Alright! I also tried on Google Chrome


#9

Alright so…

On Safari when I click on the download it redirects me and then starts downloading. However when I try to open the download in another tab I get the same message as you.

You opening them in tabs?


#10

SOLVED!!!

This has been solved now but op can’t reply cause he is on a lockout.


#11

Sorry to hear you guys are having trouble accessing this page. If you’re still unable to access the rewards let me know and we’ll send you the kits/discount codes manually.

We will also investigate why this page isn’t functioning properly in certain browsers to avoid future issues


#12

I still don’t seem to be able to get them, if you could email the links that would be amazing, thank you!:slight_smile:


#13

Done! Please check your inbox when you can


#14

I’ve tried to generate the imageline coupon on safari and on google chrome on macbook, and on my iphone. I’m getting a “whoops” message on all.


#15

Hi @bluntos, we have responded to your email, please check your inbox when you can


#16

Ya I keep getting the same thing for a couple of months now. Can I get help?


#17

Hi @CryBrd. Sorry to hear this, I’ve sent you the kits via wetransfer and included your discount code in the message. If you have any issues accessing these rewards please let us know at support@airbit.com


#18

Thank you… I appreciate it!